流程處理失敗問題彙總
問題簡介
很多情況下,我們都會遇到處理待辦時,發現流程已經被處理或者被撤回掉,而導致無法處理流程。
處理失敗場景
目前會在兩種場景下遇到流程待辦無法處理的情況,無法處理時會彈出報錯。
1. Jodoo 系統中處理流程
當節點負責人透過工作台的「我的待辦」或者應用中的「我的待辦」處理流程。
2. 透過郵件處理流程
當節點負責人透過郵件處理待辦流程,可能會遇到「流程已被其他負責人處理」等流程提示:
可能會遇到「流程已被其他負責人處理」等流程提示:
這是因爲,該流程被處理後,流程的節點負責人不再是當前負責人,或者當前流程已經不需要再處理了。
出現這種情況的常見原因如下:
其他負責人處理了該流程
問題說明
當一個節點存在多個節點負責人,且流程規則爲「任意負責人送出後進入下一節點」,此時其中一個負責人處理了流程。
原因分析
只要其中一個節點負責人對流程進行了送出、轉交、回退、結束流程等操作,其他節點負責人將無法重複處理流程,所以會提示「流程已被其他負責人處理」。
解決方案
如果是在 Jodoo 系統中,直接關閉報錯並更新頁面,該流程待辦會自動消失,無需繼續處理;如果是郵件訊息中,直接退出訊息,處理下一條訊息待辦。
流程發起人撤回流程
問題說明
當流程屬性開啟了「流程發起後允許撤回」,在節點負責人進行審核操作時,流程發起人撤回了流程。
原因分析
流程撤回後,節點負責人就不能處理該流程了,同時會提示「該流程已被處理或撤回」。
解決方案
如果是在 Jodoo 系統中,直接關閉報錯並更新頁面,該流程待辦會自動消失,等待流程發起人再次送出時後,再繼續處理;如果是郵件訊息中,直接退出訊息,處理下一條訊息待辦。
管理員處理了該流程
問題說明
Jodoo 管理員或有管理權限的人員,可以在資料管理處調整流程負責人或結束流程、刪除流程:
原因分析
當該流程節點的負責人被管理員調整爲他人,或者流程被結束、被刪除後,原來的節點負責人將無法處理該流程,所以會提示「流程已被其他負責人處理」。
解決方案
如果是在 Jodoo 系統中,直接關閉報錯並更新頁面,該流程待辦會自動消失,流程負責人更改,無需再處理該流程;如果是郵件訊息中,直接退出訊息,處理下一條訊息待辦。
流程被自動送出
問題說明
流程限時處理可以設定自動送出,若在節點負責人進行簽核操作時,觸發了節點自動送出,則負責人無法再處理該流程待辦。
原因分析
流程自動送出以後,流程繼續進行,此時負責人點擊待辦處理流程時會提示:流程已被自動送出。
解決方案
如果是在 Jodoo 系統中,直接關閉報錯並更新頁面,該流程待辦會自動消失,流程已往下進行,無需再處理該流程;如果是郵件訊息中,直接退出訊息,處理下一條訊息待辦。
流程被自動回退
問題說明
流程限時處理可以設定自動回退,若在節點負責人進行簽核操作時,觸發了節點自動回退,則負責人無法再處理該流程待辦。
原因分析
流程自動回退以後,流程回到之前的流程節點,此時負責人點擊待辦處理流程時會提示:流程已被自動回退。
解決方案
如果是在 Jodoo 系統中,直接關閉報錯並更新頁面,該流程待辦會自動消失,流程已回退,等待回退節點再次送出後再處理該流程;如果是郵件訊息中,直接退出訊息,處理下一條訊息待辦。