同步失敗問題彙總
問題簡介
當同步資料因觸發系統用量限制及同步規則設定錯誤時,會導致資料同步失敗。同步失敗時,全部資料均失敗,不會同步到表單中。
同步失敗的記錄及原因可在同步日誌中查看;
同步失敗的日誌可以根據使用需求設定輸出表同步失敗時的訊息通知,及時通知相應人員調整資料流設定。
有關同步失敗的原因和解決方案的詳細資訊,請參閱下文。
同步規則設定錯誤
問題說明
當同步規則設定錯誤時,同步資料時,同步日誌中會出現「同步設定有誤」的報錯,如下圖所示:
原因分析
這是因爲資料同步規則設定出現了問題,需要調整同步規則。可能的原因:
- 同步表單被刪除
- 欄位匹配關係全部爲空(可能是修改資料流或刪掉所有同步表單欄位)
解決方案
點擊對應的輸出表>>修改資料同步設定中的規則;
- 如果是同步表單被刪除了,需要重新選擇表單同步;
- 如果是欄位匹配關係全部爲空,需要重新設定儲存關係,至少設定一條。
超出表單資料量限制
問題說明
1. 當同步的表單爲流程表單,同步資料超過 300 條時,同步日誌中會出現如下圖所示的報錯:
2. 當同步的表單爲普通表單,同步資料超過 20000 行時,同步日誌中會出現如下圖所示的報錯:
原因分析
對於普通表單和流程表單,每次批次匯入資料具有一定限制,當超過表單本身的數量限制時,即無法同步成功,需要將同步資料控制在數量限制範圍內再同步。
解決方案
更改資料流設定,在「輸出」節點前加一個「資料篩選」節點,透過資料篩選將輸出表資料控制在數量限制範圍內。
超出版本資料量限制
問題說明
1. 當帳號爲免費版時,同步資料後超出每月 1000 條資料量限制時,同步日誌中會出現如下圖所示的報錯:
2. 任一版本帳號,當同步資料觸發版本總資料量限制時,同步日誌中會出現如下圖所示的報錯:
3. 任一版本帳號,當同步資料觸發單個表單資料量限制時,同步日誌中會出現如下圖所示的報錯:
原因分析
不同版本的帳號,會有不同的資料量限制,當同步資料超出現有的資料量限制時,則不會同步資料,需要升級版本或者購買資料量。
解決方案
1. 免費版超出 1000 條/月的資料送出限制時,可以升級版本或者等下月重新計算資料量的時候再同步。
2. 超出資料總量限制時,商業版及以上版本的使用者,可根據版本使用情況聯繫管理員進行增購或者刪除一部分表單的無效資料來釋放資料量;其他版本的使用者可以升級版本或者刪除一定無效的資料。